Jamen dog! Hvor er det JavaScript henne?
Din browser understøtter ikke JavaScript eller har ikke understøttelsen slået til. Slå JavaScript til i din browser for at se denne side ordentligt, eller opgrader til en browser, der understøtter JavaScript.
Besøgende online nu
Gæster online 2
Brugere online 0

Antal brugere: 187
Nyeste bruger: admin

Problem med og flytte side til one.com

Sidst opdateret den 3 år siden
D
DK57Juniormedlem
Skrevet d. 3 år siden
Nu ved jeg ikke om det er det rigtige gruppe jeg har skrevet i men mit problem er at jeg er ved og flytte www.dk-gravsten.dk over på one.com server, og har mysqli. Men jeg får kun ca. det halve af forsiden frem, og lige nu tester jeg den her www.dkgravsten.dk/dks/

Jeg har tilføjer disse 2 linier i maincore.php:

include_once('mysql2i.class.php');
include_once('mysql2i.func.php');

og rettet linie 12 (som nu er linie 15)
if (preg_match("/maincore.php/i", $_SERVER['PHP_SELF'])) die();

men den fejler i linie 227 som er (her ses 226 og 227)

226	define("THEME", THEMES.$settings['theme']."/");
227 $userdata = ""; $userdata['user_level'] = 0; $userdata['user_rights'] = ""; $userdata['user_groups'] = "";


og skal jeg evt. lægge hele maincore filen på
En der en som kan hjælpe med hvad der er galt?

Mvh. Torben
F
fljFusioneer
Skrevet d. 3 år siden
Alle de første warnings kyldes, at en konstruktion som

$userdata = "";    
$userdata['user_level'] = 0;

ikke længere fungerer, men skal være

$userdata = array();    
$userdata['user_level'] = 0;

Umiddelbart gætter jeg på, at det skal rettes mange steder i koden, og at det ikke er en løsning blot at undertrykke dine warnings.

Men det er ikke det, der stopper koden. Det er linie 40 i side_left.php, hvor du kalder en funktion, der hedder eregi, og som ikke længere findes i php v7. Se http://php.net/manual/en/function.ere....eregi.php.

Det problem (og tilsvarende problem med andre "udgåede" funktioner kan imidlertid ret let løses ved at inkludere dette i maincore.php (så behøver du heller ikke rette linie 12)

if(!function_exists('ereg'))            { function ereg($pattern, $subject, &$matches = []) { return preg_match('/'.$pattern.'/', $subject, $matches); } }
if(!function_exists('eregi'))           { function eregi($pattern, $subject, &$matches = []) { return preg_match('/'.$pattern.'/i', $subject, $matches); } }
if(!function_exists('ereg_replace'))    { function ereg_replace($pattern, $replacement, $string) { return preg_replace('/'.$pattern.'/', $replacement, $string); } }
if(!function_exists('eregi_replace'))   { function eregi_replace($pattern, $replacement, $string) { return preg_replace('/'.$pattern.'/i', $replacement, $string); } }
if(!function_exists('split'))           { function split($pattern, $subject, $limit = -1) { return preg_split('/'.$pattern.'/', $subject, $limit); } }
if(!function_exists('spliti'))          { function spliti($pattern, $subject, $limit = -1) { return preg_split('/'.$pattern.'/i', $subject, $limit); } }

Men jeg tror ikke det er det sidste problem, du støder på. Msåke vil det gå lettere, hvis du opgraderer din side til php-fusion v7 - det ligner en v6.
D
DK57Juniormedlem
Skrevet d. 3 år siden
Takker, det hjalp en del, der er stadig fejl i side_left linie 40. men det prøver jeg lige og se på lidt senere i dag.
Det med at eregi skal ændres til preg_matc, fandt jeg ud af senere, men så gik jeg i seng, og fik det ikke skrevet.

Jeg fik ikke lige tjekket versionen, men det er en 5.2.42, så jeg skal nok prøve og gå til en ver. 7
F
fljFusioneer
Skrevet d. 3 år siden
Vær opmærksom på, at når du opgraderer, så forsvinder de "forbedringer", du selv har lagt ind - fx i maincore.php - også. Så det kan let blive et skridt frem og to tilbage (hvis du ikke husker at få dem ind igen).

Og så er der "langt" i opgraderinger fra 5.2 til 7. Men held og lykke med projektet. lad os vide hvordan det går.
Du kan se alle diskussionstråde i dette debatforum.
Du kan ikke starte en ny diskussionstråd i dette debatforum.
Du kan ikke svare i denne diskussionstråd.
Du kan ikke påbegynde en afstemning i dette debatforum.
Du kan ikke vedhæfte downloads i dette debatforum.
Du kan ikke vedhæfte downloads i dette debatforum.
Log ind
Er du endnu ikke registreret bruger? Klik her for at oprette dig.
Glemt kodeord?
Replikboks
Du skal være logget ind for at kunne skrive en besked.
flj1 år siden#9005
Kører fint nu 5/1-21
Ken1 år siden#9004
Noen som vet hva som skjer med https://www.php-fusion.co.uk/ ? Den kjører ikke 3/1-21
helmuth2 år siden#9003
Måske var den her noget: https://www.sean.co.uk/a/webdesign/javascript_advent_calendar/
ovejnielsen2 år siden#9001
Nogen der ved hvor man kan finde et julekalender script?
helmuth3 år siden#8996
@flj: tjek din PB-indbakke ;-)