Navigation
Supportsider
Staben
Senest Online
iceman5000:45:41
flj07:24:45
helmuth11:01:13
Micschmidt22:10:28
HenningS 1 Dag
Mutolol 1 Dag
Henrik Bendtsen 3 Dage
snatur 4 Dage
Maawaens 1 Uge
tyson 1 Uge
Besøgende
Gæster online: 3

Brugere online: 0

Antal brugere: 2,763
Nyeste bruger: Maawaens
Se indlæg
 Udskriv debat
Hjælp søges efter opdatering
tyson
Hej

efter en opgradering til 7.02.07 samt den tyske rettelse til php version 7 har jeg en fejl tilbage
Logger jeg ind som admin, og vil oprette en bruger får jeg nedenstående fejl
phpfusion siger brugeren er oprette, men det er den ikke

Download kildekode  Kode
Error: Field 'user_admin_salt' doesn't have a default value



Har indsat 250 kr til PHPFUSION via Ewire
 
flj
Kørte det uden den fejl inden den tyske opdatering?

Noget i fejlmeldingen tyder på, at du ikke har fået opdateret korrekt til php-fusion version 7.02.07, men det er bare et gæt.
 
tyson
Hej Flj

Ja siden virkede før opdatering fra 7.02.05
Ellers ser andet ud til, og virke, så ærgeligt der lige skulle være en ting
Har indsat 250 kr til PHPFUSION via Ewire
 
flj
Der er et eller andet, der er gået galt, eller ikke er lavet som det skal.

Fejlen kommer fordi feltet user_admin_salt i users tabellen ikke har et sat default værdi. Feltet oprettes af setup.php med linien
Download kildekode  Kode
user_admin_salt VARCHAR(40) NOT NULL DEFAULT ''



Heraf ses, at hvis den er oprettet af setup, så er der en default værdi.

Jeg kan ikke forklare hvordan du er havnet i den situation.

Kender du phpmyadmin? I så fald kan du finde feltet der og sætte en default værdi til blank. I modsat fald, så sig lige til, så er der også en løsning på det.

jeg kn ikke garantere, at det løser problemet, men det er harmløst at forsøge.
 
helmuth
Fejlen er rettet.
 
http://helmuth.dk/
flj
Nogen detaljer?
 
helmuth
I feltet samt andre felter stod værdien None, som blev erstattet med blank ...
 
http://helmuth.dk/
Spring til debat: