Navigation
Supportsider
Staben
Senest Online
Christian
flj01:25:02
helmuth03:06:55
snatur05:52:05
eigil-t10:45:12
tojosular10:53:53
DK5723:24:27
HenningS 1 Dag
kn-aa 2 Dage
tyson 4 Dage
Besøgende
Gæster online: 3

Brugere online: 0

Antal brugere: 2,760
Nyeste bruger: Micschmidt
Se indlæg
 Udskriv debat
PHP Version
HenningS
Hej Igen.

Er der nogen løsning på at ændre version 07.02.07 så den kan opgraderes fra webhotellets php version 5.6 til version 7,02 ?

Hvis man opgraderer nu får man blot en tom hvid side, jeg har ledt efter en løsning men synes ikke at have været det sande sted.

One.com har skrevet følgende i sidste uge.

PHP-versionerne 5.6 og 7.0 er på vej til at blive udfaset. PHP 5.6 vil blive udfaset den 31. december 2018 og PHP 7.0 den 3. december 2018. Det betyder et stop for sikkerhedsopdateringer til disse PHP-versioner. Beslutningen om udfasning er truffet af PHP.net og ligger uden for One.coms indflydelse.

PHP-versionen på din hjemmeside xxxx.dk er i øjeblikket 5.6. Vi vil opgradere den til PHP 7.2, som er den højest tilgængelige version og som vil give dig den længst mulige support-levetid. Den automatiske opgradering af din PHP-version vil finde sted i første halvdel af november.

Efter opgraderingen har fundet sted, vil du stadig midlertidigt kunne nedgradere til PHP 5.6 eller 7.0. Nedgradering vil dog ikke være mulig efter 3. december. Hvis din hjemmeside kører PHP 5.6 eller 7.0 på den dato, vil den automatisk blive opgraderet til 7.2.

Hvis du har et WordPress website, er det vigtigt at du sikrer dig, at WordPress og eventuelle plugins er opdateret til nyeste versioner, hvilket kan gøres via nogle få klik i dit WordPress dashboard.

I tilfælde af at du kører andre ting, som bruger PHP, bør du forberede din side på PHP-opgraderingen og gerne snarest muligt, så du får tilstrækkelig tid til at rette eventuelle fejl, der kan forårsages af forældet kode. Læs mere om, hvordan du forbereder din hjemmeside på PHP-opgraderingen.
https://help.one....0000448877

link til php net
http://php.net/su...rsions.php

Så hvis der er den gyldne vej med et hjælpende ord er jeg meget modtagelig for hjælpen...

God dag.
Henning
 
http://www.eurodrivers.dk
tyson
Hej Henning

Ja jeg får desværre nok samme problem
Har indsat 250 kr til PHPFUSION via Ewire
 
flj
Ja, det er der.

Mulighed 1: Brug denne her fra den tyske side https://www.phpfu...#post_7838, der gør, at php-fusion v7 kører på alle PHP vesioner fra 5.3 til 7.2. Har ikke selv prøvet den.

Mulighed 2: Ret det selv ved at lave en tilføjelsesfil til maincore.php. Du skal som minimum bruge det, jeg har beskrevet i http://php-fusion...ost_122868, og nok også de, jeg har beskrevet i http://php-fusion...ost_123157. Og måske lidt mere...

20181105/flj: Forkert link rettet
Redigeret af flj d. 05-11-2018 07:15
 
HenningS
flj skrev:

Ja, det er der.

Mulighed 1: Brug denne her fra den tyske side https://www.phpfu...#post_7838, der gør, at php-fusion v7 kører på alle PHP vesioner fra 5.3 til 7.2. Har ikke selv prøvet den.

Mulighed 2: Ret det selv ved at lave en tilføjelsesfil til maincore.php. Du skal som minimum bruge det, jeg har beskrevet i https://www.phpfu...#post_7838, og nok også de, jeg har beskrevet i http://php-fusion...ost_123157. Og måske lidt mere...


Tak for hurtigt svar..

Med hensyn til mulighed 2, er det korrekt at første link henviser til den tyske side?

Jeg vil forsøge mig med mulighed 1, og vender retur med svar. skal blot lige have taget sikkerhedskopi på en af mine hjemmesider...
Henning
 
http://www.eurodrivers.dk
tyson
Wow Flj

Dejligt såfremt det virker, tak for altid god support
Har indsat 250 kr til PHPFUSION via Ewire
 
flj
Ellers må vi se på det.

Indlæg samlet 05-11-2018 06:17:30:
HenningS - nej, der var en fejl i mit link (godt spottet!), som jeg har rettet.

Hvis du kommer succesfuldt videre med at forsøge den tyske version, må du meget gerne rapportere det her - (eller spørge vis du får problemer), for jeg tror der er mange, der er eller kommer i samme situation som dig.
Redigeret af flj d. 05-11-2018 07:17
 
HenningS
Hej FLJ !

Dejligt at have dig på sidelinjen, og skønt at i har en hurtig respons, den ros skal i have i første omgang.

Jeg forsøgte at bruge emnet om update only, på hjemmesiden www.danskegodscha... og tilrettede config fil som der stod. satte webhotel til 7,2 - 7,1 og sluttelig til 7,0 - desværre var det ikke muligt at få den fulde side frem. så jeg måtte retur til 5,6

Siden viste kun højre spalte i midten..

i dag satte jeg den til version php 7,2 og følgende kom frem.

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php:296 Stack trace: #0 /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php(92): dbconnect('danskegodschauf...', 'danskegodschauf', 'MXsNRbhj', 'danskegodschauf') #1 /customers/5/e/4/danskegodschauffoer.dk/httpd.www/news.php(18): require_once('/customers/5/e/...') #2 {main} thrown in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php on line 296

jeg tilføjede som sagt i config
$db_driver = "mysqli";

Så hvad jeg har lavet galt, er et stort spørgsmål... Man har jo næsten glemt at arbejde med sådanne filskrivning efter disse rolige år...
Redigeret af HenningS d. 05-11-2018 16:34
Henning
 
http://www.eurodrivers.dk
flj
I PHP7 er det "gamle" mysql interface endelig udgået. I "den tyske" omskrivning er det helt sikkert rettet (uden at jeg ved præcis hvordan - men det er det, som din db_driver linie styrer).

Der kan imidlertid godt være nogle infusioner eller tilføjelser, som ikke er styret af det, og derfor fortsat giver problemer, som vist.

Hvis du vil undersøge, om det er forklaringen, kan du forsøge at disable alle infusioner, og se om det hjælper.

Du kan alternativt downloade tilføjelsen i #3 og tilføje de to linier vist i #4 i denne her http://php-fusion...ost_122868. Det er nok det letteste, så der ville jeg starte.
 
HenningS
Hm ! ser noget mærkeligt ud...

vedr. 3 er det denne der skal downloades ? https://www.phpcl...l#download

Sidste skrift i version fra fejl på hjemmeside lyder følgende

Warning: include_once(mysql2i.class.php): failed to open stream: No such file or directory in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php on line 19 Warning: include_once(): Failed opening 'mysql2i.class.php' for inclusion (include_path='.:/usr/share/php') in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php on line 19 Warning: include_once(mysql2i.func.php): failed to open stream: No such file or directory in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php on line 20 Warning: include_once(): Failed opening 'mysql2i.func.php' for inclusion (include_path='.:/usr/share/php') in /customers/5/e/4/danskegodschauffoer.dk/httpd.www/maincore.php on line 20

og PHP Version er 7,2
Henning
 
http://www.eurodrivers.dk
flj
Ja, det reden, der skal downloades, og så skal de 2 filer ligge på dit webhotel samme sted som maincore.php.

Fejlmeldingen tyder på, at det ikke er tilfældet (måske de skal pakkes ud?).
 
HenningS
Hej Igen.

Jeg vender tilbage med en melding efter et døgns tid. Tak for en brav hjælp indtil videre FLJ, det er sørme supert med den ekspertise der er ydet her...

Jeg tester lige det backup og sikkerhedskopiring med mere.

Fjernede elementer indtil nu Event Calendar med panel 0.8.5
- Autonews .
PM - Control version 1,7,0 skal formentlig også fjernes....

- Så venner, det er blevet tid til oprydning i infusioner....

Indlæg samlet 12-11-2018 11:13:32:
En kort beskrivelse af mine opdateringer.

Jeg har nok dummet mig lidt inden jeg startede med opdateringer på de sider jeg arbejder på, og her får i lige nogle af disse.

Slå alle elementer fra som ikke er standard på siden inden man starter med opdatering.

jeg har som udgangspunkt brugt indlæg 3 i denne listevisning.

de fleste sider er opdateret med den tyske henvisning og update, husk at rette config.php fil med det beskrevne, glemte det et par gange.

Der var også lidt rettelser på nogle af websteder at maincore, måtte have et par linjer, som også er beskrevet af FLJ.

Slå en infusion til af gangen, og hvis det ej virker, så fjern den med det samme.

Og som noget af det første - den pokkers sikkerhedskopi - den kan være guld værd.

En stor tak for hjælpen til denne sides supportere, som orientering til Helmuth - kalenderen du fandt virker. Tak for denne
Redigeret af HenningS d. 12-11-2018 12:13
Henning
 
http://www.eurodrivers.dk
tyson
Hej Flj og Henning

De to filer skal bare downloades, og ligge i samme mappe som mailcore.php ?

Hvor skal den foreslåede kode indsættes i den kode som er i filen ?

Takker for hjælpen
Har indsat 250 kr til PHPFUSION via Ewire
 
helmuth
@tyson
Se indlæg #3 ...
 
http://helmuth.dk/
HenningS
tyson skrev:

Hej Flj og Henning

De to filer skal bare downloades, og ligge i samme mappe som mailcore.php ?

Hvor skal den foreslåede kode indsættes i den kode som er i filen ?

Takker for hjælpen



Hej Tyson.

Jeg brugte den tyske rettelse som der linkes til, altså update versionen !

https://www.phpfu...#post_7838

Dog er der masser af rettelser og infusioner der ikke virker.

Så en god oprydning af infusioner er jeg godt i gang med, ligesom mine gamle indlæg bliver ryddet. Dog måtte jeg opsætte en side igen, men en ikke så aktiv side, så det lærte jeg noget af

Tak for jeres store hjælp FLJ og Helmuth, denne side har stadig sin berettigelse med den service i yder !
Henning
 
http://www.eurodrivers.dk
Spring til debat: